Subject: Re: Message "Source line too long" during make?
To: '' <>
From: Fischer, Roger <>
List: tech-pkg
Date: 05/05/1999 11:58:11
>In article <Pine.NEB.3.96.990504201443.8237A-100000@max>,
>Roger Fischer <> writes:
>> Is it an error in the source code?

>No, it is an assembler error. And the assembler file is created form
>a C++ source by "g++".

>> ... or is there something set improperly on my machine during the build?

>Did you try to do an "ulimit -d" (sh or bash) or "unlimit datasize"
>(csh or tcsh)?

Yes, I tried to build once, and got an "out of virtual memory" error
so I did an unlimit datasize and tried the rebuild again.

>> /var/tmp/cc08183a.s: Assembler messages:
>> /var/tmp/cc08183a.s:430: Fatal error:Source line too long. Please change
>> file /amd/toaster/netbsd/src/gnu/usr.bin/gas/input-scrub.c then rebuild
>> assembler.

>It seems that the mac68k toolchain is not configured properly.

I've been having a lot of trouble building this package.
I built kde-1.0 last year.  It built OK, but I had a problem
with one of the apps segfaulting on me.  I was told to rebuild
with debug flags set
	setenv CFLAGS -g
	setenv CXXFLAGS -g
That solved it for 1.0.  Should I use this for kde-1.1?

I built the kde-1.1 package once, but had problems with the
kpanel segfaulting on me.  I decided to rebuild the whole
package again.  Now I'm getting this error.  I did a
"make clean" and tried again, but got the same error.

I'm unfamiliar with the compilers, and different options that
can be set during the build and what they do.  The package
system makes it easy to build, but I'm still lost as to what
to do when things go wrong.