Subject: converters/kdesupport depends on __unix__
To: None <>
From: Andrew Gillham <>
List: tech-pkg
Date: 04/27/1999 02:01:28
The 'mimelib' appears to depend on the definition of "unix", but
it isn't set anywhere for the package.  I didn't see an obvious
fix, as 'CFLAGS+= -Dunix' didn't work.  I ended up adding a 
"|| defined(__NetBSD__)" to mimelib/config.h. 
Anyway, without this, kde won't build/install.  The kdenetwork
package gets a link error of "undefined symbol GetPid()" or similar.
Basically the mimelib is defining GetPid() to return getpid() if
__unix__ is defined. 
I did a pkg_delete of every package, and I'm trying to install things
from a bare system.  I did have kde up and running though, so I'm
not sure what's changed.  My previous version was built several
months ago.

Andrew Gillham                            | This space left blank                     | inadvertently.
I speak for myself, not for my employer.  | Contact the publisher.