Subject: databases/msyql broken?
To: None <>
From: Andrew Gillham <>
List: tech-pkg
Date: 03/04/1999 16:39:24

On -current pkgsrc/databases/mysql won't build because of errors
in the mit-pthreads directory.  These errors are:
1101: conflicting types for `bind'
/usr/include/sys/socket.h:400: previous declaration of `bind'
1123: conflicting types for `connect'
/usr/include/sys/socket.h:401: previous declaration of `connect'
1175: conflicting types for `accept'
(most of the socket functions)

This also affects the devel/mit-pthreads package.  I edited the
fd_kern.c in devel/mit-pthreads, which built ok, but the same
changes under databases/mysql wasn't quite enough.  Perhaps someone
more familiar with the package build system could take a look at this?

Is this the right list to send this to?


Andrew Gillham                            | This space left blank                     | inadvertently.
I speak for myself, not for my employer.  | Contact the publisher.