Subject: Re: package install problem
To: Matthias Scheler <>
From: Todd Vierling <>
List: tech-pkg
Date: 08/04/1998 08:00:07
On Tue, 4 Aug 1998, Matthias Scheler wrote:

: > This is because the person creating the binary pkg did it with newer pkg_*
: > tools (it should not have been done that way).
: It can NOT be done another way. This package is based on current package
: sources. And the included "" will call "pkg_create" with "-C".
: So I had to install the new packages tools on my 1.3.2 system to be able
: to build this package.

Um, CONFLICTS= only adds a @pkgcfl entry if the pkg_* tools support "-C". goes through hoops to make sure about that.  The current pkgsrc
*does* work on 1.3.x as-is.

However, I have a feeling a compatibility switch may be in order, one that
says "make pkgs compatible with 1.3, even though my tools are newer"?  I
cross-compile for 1.3 on -current systems, which is just one of the
situations where this can happen.

-- Todd Vierling (Personal; Bus.