Subject: Problem with mit-pthreads pkg
To: None <tech-pkg@NetBSD.ORG>
From: Paul Boven <>
List: tech-pkg
Date: 07/10/1998 14:54:16
Hi folks,

I hope this is the right place to bring up this problem.
I've been trying to get mysql up and running, and for that one needs
the mit-threads package.

The package compiles nicely, but when linking this happens:

bash-2.00# make
===>  Building for mit-pthreads-1.60b6
building shared pthread library (version 1.60)
ld -x -shared  -o    --whole-archive libpthread_pic.a --no-whole-archive
ld: invalid command option `--whole-archive'
*** Error code 1

This seems to be an option ld does not recognise.. does anyone know a fix,
or at least a workaround?

Regards, Paul Boven.

P.s. system is a Sparcstation IPX running NetBSD1.3.1
NetBSD 1.3.1 NetBSD 1.3.1 (GENERIC) #0: Thu Mar 12 17:30:57 MET 1998     pk@flambard:/usr/src1/sys/arch/sparc/compile/GENERIC sparc
Paul Boven, <>  PE1NUT  QRV 145.575 JO32KF
      Windows '98: Who needs an OS that has no Blinkenlights?