Subject: ath and/or net80211 troubles
To: None <,>
From: Jukka Salmi <>
List: tech-net
Date: 07/09/2005 20:37:27

using today's HEAD sources on a Soekris net4511 (acting as an access
point) and a IBM ThinkPad X40 I'm seeing (probably) net80211 or ath
related problems. The net4511 has a 3com cardbus ath card (3CRPAG175),
the ThinkPad uses a miniPCI ath card.

As soon as the laptop starts to download a large file through the AP,
the AP becomes very unresponsive; e.g. `ls' sometimes takes more than
a minute to return, even when run in an empty directory. Sometimes the
AP even reboots, probably because the watchdog timer expired (at least
I never saw a reboot after I disarmed the timer).

I already tried a kernel from before the latest net80211/ath import from
FreeBSD on the AP, but the problem was still the same. However, I don't
have an older kernel for the laptop to test right now (anybody has a i386
GENERIC_LAPTOP available from before the import?).

When running another OS on the laptop, I don't see this problem, i.e.
the AP is responsive even while the laptop generates massive traffic.

Comments and hints about how to debug this problem are appreciated.

TIA, Jukka

bashian roulette:
$ ((RANDOM%6)) || rm -rf ~