Subject: Re: Loosing carrier on wm port during autoconfiguration
To: None <>
From: Simon Burge <>
List: tech-net
Date: 09/03/2004 16:55:31
Thor Lancelot Simon wrote:

> On Fri, Sep 03, 2004 at 02:43:30PM +1000, Simon Burge wrote:
> > 
> > I have a Supermicro box with an X5DAE motherboard here, and the only way
> > I've ever gotten the on-board i82545EM to work was to plug it in to a
> > 10mbit hub and wire "media 10baseT" in my ifconfig_wm0 line.  Otherwise
> > the symptoms sound similar to yours.  Using "auto" or hard coding any
> > media type failed.
> > 
> > An Intel Pro/1000 Server PCI-X i82545EM works just fine however.  From
> It probably depends as much on the PHY as it does on the MAC.
> From my experience with these devices though I wouldn't expect any of them
> to work either with a 10Mb hub _or_ hardwired.  As far as I can tell, they
> work with link partners that support autodetection, with both ends configured
> to actually _do_ autodetection, only.

You chopped out the dmesg that said both the working and non-working
cards have "Marvell 88E1011 Gigabit PHY" phys :-)

> Maybe cards with certain PHYs do better, but every wm I've run into, whether
> on a card or embedded, basically doesn't work if it _or_ the link partner
> isn't allowed to (or can't) do Nway autonegotiation.

I'd tried the on-board wm in both a 100mbit and GigE switch with both
auto and all sorts of combinations of speeds and duplexes without
success.  It only ever worked on a 10mbit hub at half-duplex, and again
with a hardwired media line - auto didn't work.

It's almost a moot point now that I have a working wm card in there now,
but it's still annoying...

Simon Burge                            <>
NetBSD Support and Service: