Subject: IPFilter kernel and userland compatibility
To: None <>
From: Matthias Scheler <>
List: tech-net
Date: 08/17/2004 07:56:51

one of the improvements which IPFilter 4.x was supposed to deliver was
compatibility between different versions of the kernel and userland
components. But after I've upgraded my firewall running NetBSD 2.0_BETA
from a kernel with IPFilter 4.1.1 to a kernel with IPFilter 4.1.3 the
firewall rules weren't loaded before I upgraded the userland tool, too.
Isn't that exactly the thing which the new interface was supposed to fix?

	Kind regards

Matthias Scheler