Subject: Re: bge0 doesn't like to autodetect gigabit
To: Bryan Vyhmeister <>
From: Jonathan Stone <jonathan@DSG.Stanford.EDU>
List: tech-net
Date: 09/02/2003 09:59:33
In message <r02000100-1026-C3A32494DD2211D79B49000393D5E5DA@[]>Bryan Vyhmeister writ
>> I've noticed that IBM servers with onboard Broadcom gigabit ethernet
>> to have issues when connected to gigabit switches. I've tried Netgear

What kind of bge? Are these the same onboard 5703 on IBM servers for
which Matt Thomas(?)  added support, or something else again?

>> connection is going up and down). The source indicates that this are
>> printed pretty much any time bge_tick() is called.

IIRC, that message (and calling bge_tick for link events) is allegedly
a workaround for a hardware bug/misfeature on the bcm5700 chip: the
hardware link-state FSM is broken and has to be checked in software.
The driver should not be taking that path at all for a 5701 or newer.

>I have experienced the exact same problem except I am using a Supermicro
>X5SS8-GM motherboard which has an onboard bge(4) interface. I have not
>been able to get it to work with gigabit at all. 

That's what you would get if the driver is not applying the correct
PHY/DSP patch for your particular hardware revision. What rev does the
driver claim, and what are the acutal PCI register values?

>I have been using
>Linksys switches. I tried this in 1.6.1 and also -current and it does
>not seem to make a difference.

FWIW,I had no problems (once the DSP patches were correct) with
bcm5700s or 5704s, to Cisco Catalyst or Extreme Summit switches.

It would help to know *exactly* what family and chip is affected
(e.g., bcm 5703, revision a2). If the driver doesn't give that much
detail, we can figure it out from the PCI registers.