Subject: Re: PF for netbsd
To: Bill Studenmund <>
From: Manuel Bouyer <>
List: tech-net
Date: 07/06/2003 11:57:43
On Sat, Jul 05, 2003 at 05:40:49PM -0700, Bill Studenmund wrote:
> > not tag. And a m_tag prefix for these functions looks fine to
> > me (m_tag_name2tag(), m_tag_tag2name(), etc), as they're really related to
> > m_tag too.
> May I suggest calling it "pctag" for packet classifier tag? From what I've
> read, I think that Itojun has two meanings for "pf" in mind, one being
> specifically the PF packet classifying and filtering code and the other
> being a service that things like altq and IPsec can use so that they too
> don't have to also classify a packet. At the present time, the PF packet
> code is serving for both, but that can change.
> By calling the packet classification service a different name from the PF
> code (even if the PF code is the only implementation for the moment) will
> more clearly differentiate the two.
> I realize that at the moment, the pc routines may just contain something
> like:
> #ifdef PF
> 	return pf_foo();
> #else
> #ifdef IPF
> 	return ipf_foo();
> #endif
> #endif

Not really, in fact PF is a user of these functions, but there's nothing
specific to pf in them. They've been moved to uipc_mbuf2.c, and that's why
I'd like to have a different name for them, so that we don't mix these
functions with the ones implementing PF.

In the current state the affetcted functions are specific to the
PACKET_TAG_PF_TAG mbuf tag type, but they can be made more generic by adding
a second argument (I don't know if this is usefull, though)

Manuel Bouyer <>
     NetBSD: 24 ans d'experience feront toujours la difference