Subject: Mysterious arp error
To: None <>
From: Peter. Bex <>
List: tech-net
Date: 09/10/2002 19:35:36
Hello again,

My network driver is almost finished -- I hope :), anyway at least I understand mbufs (*shame*, those are quite simple) and I almost understand DMA -- but now I keep getting the following error when I try to 'ping' another computer:

arpresolve: can't allocate llinfo

Now, I've searched the NetBSD mail archives, and lots of people keep running into this problem.
The problem has been known since 1995 or so, but I'm running NetBSD-Current.
I haven't found a satisfactory explanation of the cause of this problem, except that it 'has something to do with wrong routes'.

My network setup is extremely simple:

- a Mac Quadra 650, ifconfig'ed to
- an AMD 1GHz, ifconfig'ed to
- a switch to connect the both of them (so it makes a closed network, since nothing else is connected to it)

Now, the AMD does have a custom built kernel, but I've tried to deselect a lot of options (like tunneling) and still I keep getting the error.
Also, the defaultroute in rc.conf is set to "", and when I set it to it still doesn't work.

The Mac seems to work perfectly, when I 'ping' it actually sends the packets. (and when I reboot to *shudder* Windows on the AMD, the ping works both ways)

I have placed some printfs into the kernel, so it prints whenever packets are received and it displays the ethernet addresses.
The source address is allright, and the destination is set to ''. Is this correct? (It seems like the problem might be here, but then I don't have much networking experience...)
Then the kernel automagically wants to send a return packet, and that's were it goes wrong.
I get the message that a packet is being sent from my computer to the Mac, but it gets lost somehow. No error messages from any system, though!
After 7 packets 'ping' says 'host down', and continues saying so (and no more packets are received by the AMD). Even when I ctrl-C and 'ping' again.

'route show' on the AMD only shows loopback and localhost.
On the Mac it shows the same.

So I guess now is the time to cry "HELP". :)

I hope this is enough description to work with, otherwise please tell me what you'll need.

Peter Bex