Subject: Re: Netgear FA311/12 (NS DP83815 chipset)
To: Manuel Bouyer <>
From: Bob Melson <>
List: tech-net
Date: 08/22/2002 09:02:45
Manuel Bouyer wrote:
> On Mon, Aug 19, 2002 at 03:20:10PM -0600, Bob Melson wrote:
> > I've just received several new computers equipped with the Netgear
> > FA311/312 10/100 Fast ether card, based on the Nat. Semi. DP83815
> > chipset.
> >
> > At boot the cards are recognized, they appear to configure OK using
> > ifconfig sip0 inet aaa.bbb.ccc.ddd but they seem unable to talk to
> > anybody but themselves.  I've tried running'em through a 10/100 hub,
> > straight into the net, with no joy.  What's frustrating is that I can
> > take the same or a similar box, load FreeBsd on it and, voila!,
> > communications; same with Linux.
> >
> > System level is i386 1.5.2.  I've tried also with 1.5.3 with same
> > results.
> There are known bugs in 1.5.2's sip but I though 1.5.3 was correct.
> Can you try a 1.6_RC1 snapshot ?

Loading 1.6 in beta on these machines would be inappropriate at this
point, as they're to go into a production environment.  The frustration
is that the 1.5.3 system clearly senses the cards, as reported by dmesg,
or the network configuration portion of the install floppies. 
Unfortunately, that's where it ends.  Even though the cards appear to
config correctly, they absolutely do not talk on the network.  Swapping
the netgear card out for, say, an intel 10/100 card and configing with
the same information (domain, hostname, ip, gateway, etc) results in
clean communications on the net, so I'm left thinking that it's the
driver for the card.


> --
> Manuel Bouyer <>
> --

Bob Melson		They have rights who dare maintain them."
Unix Administrator		--James Russell Lowell
Dept. of Biology
New Mexico State University
Las Cruces, NM (505)-646-1531 (v), (505)-646-5665 (fax)