Subject: DE650 Dlink card/PCMCIA/IRQ problem
To: None <,>
From: Parity Error <>
List: tech-net
Date: 03/27/2002 21:55:36
I had a problem getting my pcmcia network card to work and i had posted 
to netbsd-help sometime back. After BREAKING my head (thank god its still
intact), i 
managed to find out what the problem was ->  no irq's were being received by
the system from the card. It was able to send arp queries but not the reponses.
This also explained why i got ne2: device timeout. 

So what did i do ?, i hard coded irq to 3 in 
dev/isa/i82365_isasubr.c:pcic_isa_chip_intr_establish after isa_intr_alloc().
And it 
worked. Adding a printf at dp8390_intr verified that it was now interrupting.

I still dont know why it was broken. Could it be that ints >8 cannot be called
from my 
pcmcia card ? I would appreciate if someone could accurately tell what the
was and fix up the kernel sources if necessary.

Here is the original post on this
I have an old Compaq laptop with a PCMCIA based D-Link network card.
The card model is DL-650. I am running Netbsd -current 1.5ZA. 

i did ifconfig ne2 <myip> <netmask> up
and a kernel message
pcmcia0: card irq 10

and i tried to ping a local machine. The dest machine gets arp queries and that
to it. But on my laptop, the ne2 cards seems unable to pick up any of the
I keep getting ne2: timeout and ping says host is down. I dont think there is
irq conflict (from what i guess looking at the bootup messages). What could be
problem ?

The system bootup messages 
NetBSD 1.5ZA (INSTALL_TINY) #0: Wed Mar 27 03:27:51 PST 2002
cpu0: Intel 486DX (486-class)
total memory = 3964 KB
avail memory = 1256 KB
using 20 buffers containing 81920 of memory
mainbus0 (root)
isa0 at mainbus0
wdc0 at isa0 port 0x1f0-0x1f7 irq 14
wd0 at wdc0 channel 0 drive 0: <Conner Peripherals 240MB - CP2251>
wd0: drive supports 16-sector PIO transfers, chs addressing
wd0: 240 MB, 489 cyl, 16 head, 63 sec, 512 bytes/sect x 492912 sectors
npx0 at isa0 port 0xf0-0xff: using exception 16
pc0 at isa0 port 0x60-0x6f irq 1: color
pc0: console
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
pcic0 at isa0 port 0x3e0-0x3e1 iomem 0xd0000-0xdffff
pcic0: controller 0 (Cirrus PD672X) has sockets A and B
pcic0: controller 1 (Intel 82365SL Revision 1) has no sockets
pcmcia0 at pcic0 controller 0 socket 0
pcmcia1 at pcic0 controller 0 socket 1
pcic1 at isa0 port 0x3e2-0x3e3 iomem 0xe0000-0xe3fff
pcic1: controller 0 (Intel 82365SL Revision 1) has no sockets
pcic1: controller 1 (Intel 82365SL Revision 1) has socket A only
pcmcia2 at pcic1 controller 1 socket 0
biomask fffd netmask fffd ttymask ffff
pcic0: using irq 9 for socket events
pcic1: controller 1 detecting irqs with mask 0xde00: none
pcic1: no available irq; polling for socket events
md0: internal 1440K image area
ne2 at pcmcia0 function 0 port 0x300-0x30f port 0x310-0x31f
ne2: D-Link DE-650 Ethernet
ne2: Ethernet address 00:80:c8:81:a2:09
wd0: no disk label
boot device: fd0
root on md0a dumps on md0b
root file system type: ffs
wd0: no disk label
wd0: no disk label
wd0: no disk label
wd0: no disk label
wd0: no disk label
pcmcia0: card irq 10