Subject: Re: How to increase the socket buffer in netbsd 1.3.2
To: diepchitran <>
From: Jonathan Stone <jonathan@DSG.Stanford.EDU>
List: tech-net
Date: 04/17/2001 12:02:54
In message <>diepchitran writ

>I use ttcp to run a test on a  long delay and high speed testbed (the
>bandwidth-delay-product is 3.125MByte). When I set the -b (socket buffer
>size ) option greater than 1.6MByte, I get an error message "no buffer
>space available" ( errorno:55). I increased the SB_MAX to 6.25MByte (2*BDP)
>,  the tcp_sendspace and tcp_recvspace to 65K and 6.25MBbyte, and the
>NMBCLUSTERS to 8194, but I still get the same error message. Is there any
>limitation on socket buffer size in version 1.3.2 ?. If not, could you
>please show me what I should do to increase the socket buffer size?. 
>Thank you very much,


Expertise on netbsd 1.3 may be hard to find; it may be a case of UTSL.

If netbsd 1.3 has sysctl, i'd use sysctl -a | grep tcp | grep space to
verify that the tcp limits were indeed increased; and double-check
that rfc1323 (PAWS) is turned on.

Then i'd check that the kernel variable sb_max is large enough for the
buffers you want to allocate. (if 1.3.x has sb_max, that'd be my
guess; its usually around 240k on a 1.4 system).

Last, if all those look OK, i'd then try running the ttcp as root, if
you hadn't already done that.