Subject: ne2000 pcmcia clone on Compaq Armada 1598
To: None <,>
From: Steve Woodford <>
List: tech-net
Date: 04/02/2000 21:31:01

Yesterday I brought NetBSD-current up on a Compaq Armada laptop, from a
snapshot CDROM. Everything is working great, apart from this piece of junk
SOHOware ne2000 clone PCMCIA network card.

The Armada's PCMCIA bridge claims to be i82365 compatible, and at this
time I have no reason to believe this is not the case.

However, the network card's Manufacturer and Product codes probe as
"0xffffffff" so I added a quirk entry in pcmcia_cis_quirks.c with the
relevant CIS strings ("NDC", "Ethernet") and ccr address/mask (0x3f8/3).
I also added the relevant entry in if_ne_pcmcia.c for the card, although
I've had zero luck finding the ethernet address.

The end result is, this card always reports "ne0: where did the card go?"
whenever it is inserted. I tried adding NE2000DVF_AX88190 to the entry in
if_ne_pcmcia.c, which things a bit further, to the point where the driver
appears to attach but ifconfig(8) results in errors reporting that "remote
DMA timed out" (or words to that effect).

On the off-chance, I also tried PCIC_ISA_ALLOC_IO{BASE,SIZE} in the kernel
config file, with no effect.

I've pretty much exhausted my supply of clues with this problem, so any
additional clues would be most welcome!

Cheers, Steve