Subject: Re: iy0 screwed in NetBSD-1.4 ?
To: Darren Reed <>
From: Kevin P. Neal <>
List: tech-net
Date: 01/22/2000 01:19:38
On Fri, Jan 21, 2000 at 12:37:04PM +1100, Darren Reed wrote:
> I'm running NetBSD-1.4 and have periodic lockups of network IO on iy0.
> To releive this, I run the following from rc.local

Thanks for the tip. 

> # cat fixiy0

> So anyway, the above gets run and the most iy0 gets locked up for is
> 60 seconds.

That's handy. 
> Now, having said all of the above, I've been testing this new Denial Of
> Service program called "stream.c" locally, on the same lan.  I ran it
> from another NetBSD box against a Solaris box - i.e. *not* targetting
> the box with iy0.
> Having said that, running this test generally results in iy0 getting
> locked up to the point where "netstat -m" returns 15% buffers in use
> but "ping" returns "No buffer space available".  thorpej
> tells me this may be a if-queue error being returned.
> I get the feeling that perhaps there are some serious problems with the
> iy driver.  Has anyone else seen anything like this ?

Yes, but not on iy. I'm seeing ppp lock up, and the symptoms sound 
pretty similar. 

My box sometimes has it's ppp connection to the net (which is full time)
locked. No traffic comes in or out. A ping of anything on the net from
the box gives the "No buffer space available", despite the fact that
netstat says I have mbufs left. 

Sending pppd a HUP causes it to drop the connection and redial, which
seems to clear up the problem (until it happens again). 

BTW, does this look like my box is being scanned?: (from netstat for tcp)

        4778 connection requests
        2722 connection accepts
        5994 connections established (including accepts)
        7498 connections closed (including 31 drops)
        1498 embryonic connections dropped

This is on an Alpha 1.4.1 box.
Kevin P. Neal                      

"She's a sonic magician."     Ross Smith really likes Ani Difranco.
                                                   April 22 1999 2:14am