Subject: iy0 screwed in NetBSD-1.4 ?
To: None <>
From: Darren Reed <>
List: tech-net
Date: 01/21/2000 12:37:04
I'm running NetBSD-1.4 and have periodic lockups of network IO on iy0.
To releive this, I run the following from rc.local


# cat fixiy0
(while /usr/bin/true; do ping -c 2 >/dev/null 2>&1; sleep 30; done&)
while /usr/bin/true; do
        /usr/sbin/tcpdump -c 4 -i iy0 -w /dev/null >/dev/null 2>&1
        sleep 60
exit 0


So anyway, the above gets run and the most iy0 gets locked up for is
60 seconds.

Now, having said all of the above, I've been testing this new Denial Of
Service program called "stream.c" locally, on the same lan.  I ran it
from another NetBSD box against a Solaris box - i.e. *not* targetting
the box with iy0.

Having said that, running this test generally results in iy0 getting
locked up to the point where "netstat -m" returns 15% buffers in use
but "ping" returns "No buffer space available".  thorpej
tells me this may be a if-queue error being returned.

I get the feeling that perhaps there are some serious problems with the
iy driver.  Has anyone else seen anything like this ?