Subject: Re: kern/1515 [Re: PR-7148 (causes kernel panic)]
To: Manuel Bouyer <bouyer@antioche.lip6.fr>
From: Christos Zoulas <christos@zoulas.com>
List: tech-net
Date: 11/02/1999 13:38:29
On Nov 2,  7:04pm, bouyer@antioche.lip6.fr (Manuel Bouyer) wrote:
-- Subject: Re: kern/1515 [Re: PR-7148 (causes kernel panic)]

| On Tue, Nov 02, 1999 at 12:23:11PM -0500, Christos Zoulas wrote:
| > Looks fine to me, two points:
| > 1. why 'struct if_odata' as opposed to 'struct if_data14'?
| 
| Don't know, I'll rename it to if_data14 :)
| 
| > 2. what is the decision between %qd and %lld? Isn't the second more
| >    portable?
| 
| Darren used %qd, I just changed the few ones which were missing.
| If you tell me %lld is better I'll use %lld, I don't have any idea of what 
| printf formats are portable or not for such types (is u_quad_t portable ? )

I don't know. NetBSD developers are using %qd most of the time. When I
started porting our /usr/bin/ to solaris, I changed a lot of them to %lld.
I am not particularly concerned for the kernel code, but for userland.
I think that for maximum portability one should use:

	"%ulld", (unsigned long long) u_quad_t_variable_name
	"%lld", (long long) quad_t_variable_name

Opinions?

christos