Subject: Odd behavior--explainable?
To: None <tech-net@NetBSD.ORG>
From: Allen Briggs <>
List: tech-net
Date: 06/18/1998 23:30:08
I've got two NetBSD/i386 systems--one running -current as of a couple of
days ago (+ bouyer's IDE patches), one running 1.3.1.  I was trying to
ftp get on the 1.3.1 machine, pulling from the -current machine.  Both
systems have DEC ethernet controllers (both AF, I think) running at
100Mbit, half-duplex.  They're attached to a hub with an uplink to a
switch and one other (relatively low-trafficed) host on the hub.
The ftp was stalling.  I said to myself--"This isn't right.  I should
run tcpdump to see what, if anything, is transpiring."  So I ran
'tcpdump "host hostA and host hostB"'.  As soon as I did that, I started
getting something like 1-2MB/sec.  Still not fabulous, but respectable.
Since this was a relatively huge file (1.2G), I stopped tcpdump and
restarted it a couple of times.  Whenever I stopped tcpdump, the ftp would
slow way down.  Whenever I restarted tcpdump, the ftp would proceed at a
more acceptable pace again.

Any thoughts?


                    Allen Briggs -