Subject: Re: rarp failing
To: Chris G Demetriou <>
From: Mark Newton <>
List: tech-net
Date: 10/26/1996 22:48:20
Chris G Demetriou wrote:

 > You say that tcpdump shows the replies on the net but your Sun 3/60's
 > aren't seeing them... that sounds more like a bug in either your
 > configuration or in the sun3 network boot blocks.

... or the Sun-3 boot PROM isn't recent enough to understand 
all-ones style broadcasts.

I run my Sun-3/60 on a class-C ethernet ( with
a FreeBSD server.  My Sun was completely unresponsive to netbooting
until I went to the FreeBSD system and said,
"ifconfig ed0 broadcast".  After that it worked
flawlessly (with SunOS 4.1.1 and a snapshot of NetBSD-current from

So, either the Sun doesn't understand all-ones, or FreeBSD isn't
backwards-compatible enough to deal with all-zeros when its broadcast
is all-ones.  Either way, server and client have to match for it to

Could this be what's plaguing you, Vax?

    - mark

I tried an internal modem,                
     but it hurt when I walked.                          Mark Newton
----- Voice: +61-8-83732429 ------------- Data: +61-8-83736006 -----