tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: __{read,write}_once

On 16.11.2019 15:31, Mindaugas Rasiukevicius wrote:
> Maxime Villard <> wrote:
>> Alright so let's add the macros with volatile (my initial patch). Which
>> name do we use? I actually like __{read,write}_racy().
> I suggest __atomic_load_relaxed()/__atomic_store_relaxed().  If these
> are to be provided as macros, then I also suggest to ensure that they
> provide compiler-level barrier.

I'm in favor of this naming.

Attachment: signature.asc
Description: OpenPGP digital signature

Home | Main Index | Thread Index | Old Index