tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: __{read,write}_once

On 11/15, Maxime Villard wrote:
> Alright so let's add the macros with volatile (my initial patch). Which name do we
> use? I actually like __{read,write}_racy().

+1.  I'm a fan of avoiding the "once" terminology just because the first
thing that comes to my mind is the threading concept of a function that
does something only one time regardless of how many times it is called
and regardless of from which thread it is called.


Home | Main Index | Thread Index | Old Index