tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: __{read,write}_once

On 06.11.2019 16:58, David Young wrote:
> I *think* the intention is for __read_once()/__write_once() to
> load/store the entire variable from/to memory precisely once.  They
> provide no guarantees about atomicity of the load/store.  Should
> something be said about ordering and visibility of stores?

The original intention is to mark reads and writes racy-OK.

once is a bad name as it suggests some variation of RUN_ONCE(). I am for
memory ordering name relaxed, borrowed from the terminology atomics.

Attachment: signature.asc
Description: OpenPGP digital signature

Home | Main Index | Thread Index | Old Index