tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Deferred freeing of kauth_cred_ts

On Fri, 25 Dec 2009, Elad Efrat wrote:

+static void
+kauth_cred_free_now(kauth_cred_t cred)

since this function is so small and only called from one place (by
design), should it not just go there?

+static void
+kauth_thread(void *cookie)

and eg call this kauth_cleanup_thread (or if you think of a better name
use that :)

+       SLIST_INSERT_HEAD(&kauth_thread_discard, cred, cr_list);

should access to this SLIST be protected by a mutex?  There could be a
race between adding and removing..


Home | Main Index | Thread Index | Old Index