tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

uarea related cleanup


To finish uarea clean-up and remove struct user (and sys/user.h), I would
like to make few changes in our MD code:

- Rename lwp_t::l_addr to l_pcb, and replace USER_TO_UAREA/UAREA_TO_USER
  et al macros with uvm_lwp_getuarea() and uvm_lwp_setuarea() routines.

- Minimise direct access of lwp_t::l_addr/l_pcb by replacing them with a new
  lwp_getpcb(lwp_t *l) routine.  Mainly assembler would use l_pcb directly.

This should give a slightly better abstraction and small simplification.



Home | Main Index | Thread Index | Old Index