[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: on getting rid of KAUTH_GENERIC_ISSUSER
Christoph Badura wrote:
So, it seems to me that the first step in that direction should be
to rename that constant to KAUTH_GENERIC_ISPRIVILEGED or ..._ISAUTHORIZED.
There's a serious confusion here. The check is not whether the credentials
presented are those of the super user. The check is whether the credentials
can be authorized to perform some unspecific privileged operation.
The check that the credentials are the super-user's is only made in
Any objections to that?
Yes. Changing the name does not help in any way to solve the real
problem, which is that the operation is unspecified. I don't see why
waste time and energy on search-and-replace commits when you can invest
them in actually properly classifying the place-holders.
FWIW, KAUTH_GENERIC_ISSUSER originates in Apple's implementation and was
never intended to be anything more than a place-holder. A discussion
will be held at some point in the future about whether or not we want an
"unspecified privileged operation authorization action" to be present or
not, along with its implications on secmodels, logging, etc.
Main Index |
Thread Index |