tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Locking interface in "libprop" implementation

In most case the usage is like Y->X_rwlock. What is the difference to grep by 'Y->X_rwlock' instead of X_rwlock?
Anyway the stucture's members are called in one style. There is impotant to save style at least inside the structures.

On Wed, May 7, 2008 at 7:20 PM, Brett Lymn <> wrote:
On Wed, May 07, 2008 at 03:15:21PM +0300, Andy Shevchenko wrote:
> I suppose pa_rwlock & pd_rwlock could be renamed to the rwlock. There is
> more simple to resolve name disadvantage.

As was pointed out to me in the past having names like pa_rwlock and
pd_rwlock makes grepping the source of instances of their usage a lot
more accurate than if you use something like rwlock which would require
you to sift through many many more hits to find the particular ones you
are interested in.

Brett Lymn
The information contained in this email and any attached files is
confidential to BAE Systems Australia. If you are not the intended
recipient, any use, disclosure or copying of this email or any
attachments is expressly prohibited.  If you have received this email
in error, please notify us immediately. VIRUS: Every care has been
taken to ensure this email and its attachments are virus free,
however, any loss or damage incurred in using this email is not the
sender's responsibility.  It is your responsibility to ensure virus
checks are completed before installing any data sent in this email to
your computer."

With Best Regards,
Andy Shevchenko

Home | Main Index | Thread Index | Old Index