tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: OpenFirmware, node numbers, handles etc.

(Sorry, catching up...)

On Nov 28, 2007, at 9:27 AM, Tim Rightnour wrote:

However, I think it would be better if we instead did what uwe suggests, and create things like phandle_t, ihandle_t, etc etc. It would improve readability too. We could also define some simple macros like VALID_PHANDLE(x) that would prevent people from doing things like >0. (well, not prevent, but encourage)

ofw_ihandle_t, ofw_phandle_t, OFW_IHANDLE_INVALID and OFW_PHANDLE_INVALID as manifest constants, etc.

-- thorpej

Home | Main Index | Thread Index | Old Index