Subject: Re: unable to dump kernel core
To: David Holland <>
From: Antti Kantee <>
List: tech-kern
Date: 11/06/2007 12:55:01
On Mon Nov 05 2007 at 21:21:51 -0500, David Holland wrote:
> On Sun, Nov 04, 2007 at 10:26:13PM +0200, Antti Kantee wrote:
>  > For some time now I've been unable to get a kernel coredump from a system.
>  > At first I thought the system merely hung without panicking, but recently
>  > I discovered that it was in fact either "syncing disks" or "dumping to .."
>  > which made the system hang (this was fairly difficult to see from X).
>  > 
>  > I tried it in qemu also with the same result.  It seems that the I/O
>  > for reading the swap device disklable never finishes and it is waited
>  > for indefinitely:
> Is it deadlocked?
> IME, after a FS-related panic, "syncing disks" usually deadlocks, or
> at least it seems to.

I think it's simply waiting for an event which never comes.  It appears
it's only trying to read the disklabel.

But, now that you mention it, I do recall that the system was able to
dump core when it panicked with the multithreaded gdb issue.

Antti Kantee <>                     Of course he runs NetBSD                
    "la qualité la plus indispensable du cuisinier est l'exactitude"