Subject: Re: kernel driver support for Dell 5/iR raid controller
To: Brandon Lee <>
From: Brian A. Seklecki <>
List: tech-kern
Date: 09/26/2007 08:46:29
If we're talking about "PERC5/i", then the driver is "mfi(4)", at least
on FreeBSD/amd64.  We probably have it in -current.  I know that PERC5
ships integrated in the 1950/2950 -- I didn't know they had a workgroup
server version.

I know because is leading me to new ways of suffering.  Unlike the 8th
gen PowerEdge which had a relatively well supported and documented PERC4
and open-source "megarc(8)" management CLI, the PERC5 is buggy as hell
and the megacli(8) linux-only binaries require Linux Emulation on
production servers to monitor. 

Newer firmware may fix the problems, we're checking now.  PERC5 doesn't
get my endorsement yet for production environments.  Dell/AMI/LSI will
eventually come around.


On Wed, 2007-06-27 at 22:40 +0800, Brandon Lee wrote:
> Hi,
> Recently i have got a DELL SC440 that comes with RAID controller(Dell
> Serial-Attached SCSI 5/iR controller).  I was installing the server
> with NetBSD4 200706230002Z snapshot iso but the installer complain
> that there was no harddisk found.
> Tried to boot off CentOS 5 and manage to find out the RAID Controller
> device is "LSI Logic / Symbios Logic SAS1068 PCI-X Fusion-MPT SAS"
> using mptbase and mptsas linux kernel modules.  Have tried to google
> on BSD variants with that RAID controller and the closest match was
> OpenBSD mpi driver.
> Are there any work on this driver support in NetBSD?  Attached is my
> dmesg during installation.