Subject: Re: CVS commit: src
To: None <>
From: YAMAMOTO Takashi <>
List: tech-kern
Date: 09/04/2007 17:54:02
> On Mon,  3 Sep 2007 12:05:11 +0900 (JST)
> (YAMAMOTO Takashi) wrote:
> > "generic string" means a opaque value whose meaning is only known to
> > the specific driver, right?  does the opaqueness help the script?
> My intention wasn't to make it opaque, ENVSYS_GSTRING uses the
> genstr member in envsys_data_t that is defined as:
> char genstr[ENVSYS_DESCLEN]
> so it's an array of 32 chars. But it's generic in the sense that you
> can add the string that you want on it, perhaps the name is not the
> best one... but I was out of ideas.

i'm not sure how it's generic, compared to, say, ENVSYS_INTEGER.
are you going to rename ENVSYS_INTEGER to ENVSYS_GINTEGER? :-)

probably you want to define and document how its contents should be parsed.
otherwise it's quite opaque and unusable for scripts.