Subject: Re: Scheduler API changes for yamt-idlelwp
To: Andrew Doran <>
From: Mindaugas R. <>
List: tech-kern
Date: 02/19/2007 23:26:26
Andrew Doran <> wrote:
> I'm not sure if it is worth #ifdefing this just yet. I think it would make
> more sense to have other schedulers provide a dummy routine that just
> returns and does nothing.
Would be good to make such SCHED_4BSD remnants cleaner.. :) Probably making a
dummy routine is cleaner.

> +sched_rqinit()
> Perhaps call it sched_init()?
In fact, sched_rqinit() will be per CPU soon (or even now). Current name could
be better, as in sched_rqinit() will/could be initialized not only runqueues,
but also, for example, mutexes, pools or other. But sched_init() confuses
with "general scheduler init".

> +sched_setup()
> This kicks off scheduling, right? So why not sched_start() or something?
Well, not only kicks off.. but such name is reasonable.

Best regards,