Subject: Re: Renaming l_priority and l_usrpri
To: Mindaugas R. <>
From: Andrew Doran <>
List: tech-kern
Date: 02/19/2007 19:31:10

On Mon, Feb 19, 2007 at 01:52:46AM +0200, Mindaugas R. wrote:
> Quentin Garnier <> wrote:
> > Don't get me wrong:  I'm all for better code readability.  But re-using
> > a name for a different field might be very confusing for anyone
> > maintaining code that uses that field.  That's the kind of failure I'd
> > really not want to debug myself.
> That's fully understandable. Maybe use something like l_eprio and l_prio
> instead? Then more or less we will avoid re-using of l_priority. 

I like the l_eprio and l_prio idea also. The sysctl interface and libkvm
(for crash dumps) will need to be updated, but that doesn't stop the change.
We will probably need other fields for priority lending (turnstiles), but
these ones would live on regardless I think.