Subject: re: Renaming l_priority and l_usrpri
To: Mindaugas <firstname.lastname@example.org>
From: matthew green <email@example.com>
Date: 02/19/2007 11:59:56
Pavel Cahyna <firstname.lastname@example.org> wrote:
> The field names in struct kinfo_lwp should not change. This structure is
> AIUI supposed to stay compatible.
Yes, but I am not sure if we will avoid this. It is likely that we will need
to change it with scheduler abstraction changes and/or "LWPization" (p_pctcpu,
p_estcpu existence) - see Daniel's mail about scheduler API.
In any case, this definitly needs a consideration.
they should not be renamed or moved. if things need to change
here, then new entires should be added and used, and as much
compat filled into the old ones as possible. (please see the
comment above struct kinfo_lwp in sysctl.h.)
i like the prio/eprio idea - it avoids replacing confusion with