Subject: Re: Renaming l_priority and l_usrpri
To: None <email@example.com>
From: Pavel Cahyna <firstname.lastname@example.org>
Date: 02/19/2007 00:38:07
On Mon, Feb 19, 2007 at 01:29:49AM +0200, Mindaugas R. wrote:
> as discussed with Andrew (ad@), l_priority and l_usrpri names in struct lwp
> are not very suitable and he suggested to rename l_priority to l_epriority
> ("effective priority") and l_usrpri to l_priority. These changes would go to
> yamt-idlelwp branch. Any comments?
> Here is the patch for src/sys:
> Except bin/ps and lib/libkvm, there are probably nothing more in userland.
The field names in struct kinfo_lwp should not change. This structure is
AIUI supposed to stay compatible.