Subject: Re: Renaming l_priority and l_usrpri
To: Mindaugas R. <rmind@NetBSD.org>
From: Quentin Garnier <firstname.lastname@example.org>
Date: 02/19/2007 00:36:59
Content-Type: text/plain; charset=us-ascii
On Mon, Feb 19, 2007 at 01:29:49AM +0200, Mindaugas R. wrote:
> as discussed with Andrew (ad@), l_priority and l_usrpri names in struct l=
> are not very suitable and he suggested to rename l_priority to l_epriority
> ("effective priority") and l_usrpri to l_priority. These changes would go=
> yamt-idlelwp branch. Any comments?
Don't get me wrong: I'm all for better code readability. But re-using
a name for a different field might be very confusing for anyone
maintaining code that uses that field. That's the kind of failure I'd
really not want to debug myself.
Quentin Garnier - email@example.com - cube@NetBSD.org
"You could have made it, spitting out benchmarks
Owe it to yourself not to fail"
Amplifico, Spitting Out Benchmarks, Hometakes Vol. 2, 2005.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (NetBSD)
-----END PGP SIGNATURE-----