Subject: Re: powernow k8 problem
To: IWAMOTO Toshihiro <>
From: billk01 <>
List: tech-kern
Date: 12/13/2006 14:59:10
The powernow_k8 debug message is the same whether I use an ACPI kernel 
or non-ACPI kernel. Either way it says the following:

k8pnow_states: before the for loop
k8pnow_states: returns 0!
k8_powernow_init: returned 0!
k8_powernow_init: k8pnow_current_state is NULL!

Would it help to also attach my dmesg for the non-ACPI kernel?


IWAMOTO Toshihiro wrote:
> At Mon, 11 Dec 2006 22:36:46 -0500,
> billk01 wrote:
>> Thought I would reply to my own post in case somebody wants to read a 
>> bit more and pass on some help.
>> I have built and installed (using NetBSD4 beta2 for amd64 and 
>> built a kernel with options POWERNOW_K8 and options POWERNOW_DEBUG.  
>> Still no luck with powernow.  I tried with and without acpi. I have 
>> attached my dmesg for the kernel with acpi.  Any help would be appreciated.
> powernow_k8 code only reads BIOS tables, which is documented as
> obsolete in the specification.  I guess your machine has a powernow
> table only in ACPI.
> --
> IWAMOTO Toshihiro