Subject: Re: eap recording broken?
To: Jukka Marin <>
From: Antti Kantee <>
List: tech-kern
Date: 10/11/2006 20:48:47
On Wed Oct 11 2006 at 20:14:59 +0300, Jukka Marin wrote:
> Hello,
> I'm trying to bring a -current system into production use.  One of
> the problems I'm seeing is that recording from Ensoniq AudioPCI
> card produces 8 wrong samples at regular intervals which generates
> a ticking background noise in the recorded audio.  The samples
> seem to be part of the recorded audio signal, they just come from
> a wrong place.  The number of wrong samples always seems to be 8.
> I recorded a 1 kHz size wave which makes the problem clearly visible:
> The same audio card worked just fine under NetBSD 2.0, but causes
> this problem under -current.  The computer is not the same one, though.
> The problem does _not_ occur with auich audio on the same computer
> with the same software.  This is an amd64 system running i386 port.

I also ran into a clicking problem recently, where recording produced
clicks even though there was nothing connected to the port.  I didn't
yet have time to track it down, but IIRC I tried three different sound
cards: eap@pci, emuxki@pci and sb@isa and they all had the same problem.
My clicks were always one sample in length and varied in amplitude.

So it's probably a more general problem.  But I cant't theoreticize why
you don't see it with auich.

Antti Kantee <>                     Of course he runs NetBSD                
    "la qualité la plus indispensable du cuisinier est l'exactitude"