Subject: Re: p_flag in struct proc: int -> uint64_t
To: Andrew Doran <ad@netbsd.org>
From: Jason Thorpe <thorpej@shagadelic.org>
List: tech-kern
Date: 10/05/2006 14:48:01
On Oct 5, 2006, at 9:37 AM, Andrew Doran wrote:
> Nice addition. My two comments relate to style. Please feel free to
> brick
> me for that. :)
Ok :-) (just kidding :-)
> 'specificdata' is a lot of typing and doesn't signify much to me.
> How about
> 'tag' instead?
Well... again, I tried to modeled this after pthread_{get,set}specific
(), so that's where the "specificdata" name comes from. Also, note,
this is a set of subroutines for other subsystems to use. Other
subsystems will provide the simpler, consumer-level APIs that are
essentially wrappers around these subroutines. I also feel that "tag"
is too generic a term for what this is... or at least, not quite
semantically correct. "Tag" in my mind is "associate some fixed well-
known value with an object", e.g. "tag the object as dirty", where
this is "get the object-specific value corresponding to this key".
>
> There are a few things I would prefer to see shortened for
> readability, for
> example:
>
> specificdata_container_t specdataref_container
> -> tag_container_t tr_container;
>
> specificdata_getspecific()
> -> tag_get()
>
> Thanks,
> Andrew
-- thorpej