Subject: Re: p_flag in struct proc: int -> uint64_t
To: Jason Thorpe <>
From: Andrew Doran <>
List: tech-kern
Date: 10/05/2006 17:37:52

On Wed, Oct 04, 2006 at 11:39:13PM -0700, Jason Thorpe wrote:

> Ok, here is a generalized (and currently untested) "specificdata"  
> implementation, based on Yamamoto-san's.  proc, lwp, and session  
> specific-data could be built on top of this, a'la (note this is  
> incomplete):

Nice addition. My two comments relate to style. Please feel free to brick
me for that. :)

'specificdata' is a lot of typing and doesn't signify much to me. How about
'tag' instead?

There are a few things I would prefer to see shortened for readability, for

	specificdata_container_t specdataref_container
	-> tag_container_t	tr_container;

	-> tag_get()