Subject: re: Moving scheduler semantics from cpu_switch() to kern_synch.c
To: Matt Thomas <firstname.lastname@example.org>
From: matthew green <email@example.com>
Date: 09/20/2006 09:34:37
matthew green wrote:
> Instead cpu_idle() should I think we should add a member to cpu_info
> which indicates cpu_idle should continue to loop. When nonzero, it
> represents that there may be a new lwp to be run.
> why can't this just use sched_whichqs instead of a new member?
Because we are trying to make the MD routines be independent of the
OK, why can't we use a single value instead of a per-cpu one?