Subject: Re: auich / real player / suse 10.0 under current -> audio broken
To: Steven M. Bellovin <>
From: Vincent <>
List: tech-kern
Date: 03/26/2006 11:53:07
Steven M. Bellovin a écrit :

> I've had some trouble with a recent kernel about the volume levels.
> What does mixerctl outputs.master say?  I've always set that in
> rc.local (and /etc/apm/resume); recently, I found it at 127,127 and was
> unable to change it.  Quite mysteriously, it's now working; I'm not
> certain why, but I may have done a warm reboot from Windows.

I have the same problem on another (old) machine running current. Since 
the powerhook was created, and the corresponding error message during 
boot (cannot set power or something similar) appeared, I cannot set the 
volume (outputs.master) under 127. It says here, and each time I try to 
lower it, I get the same error message on console (cannot set power). 
Strange behaviour.

I tried to comment the corresponding section of the switch in auich.c: 
it is slightly better, but Realplayer is still mute. Mplayer works 
again, though.