Subject: Re: CVS commit: [elad-kernelauth] src/sys/kern
To: None <>
From: YAMAMOTO Takashi <>
List: tech-kern
Date: 03/13/2006 07:20:06
[ moved from source-changes ]

> > as far as you hide it by a sane api, there's nothing wrong with
> > using memcmp (or memcmp-like loop which compares each gids) internally.
> The thing is, there's a different meaning to cr_groups in kauth(9),
> so I'm not sure (yet) how possible it will be to use memcmp() or such.

can you explain "the different meaning"?

> > btw, i think the name "kauth_cred_compare" should be reserved for
> > a function which compares two kauth_cred_t. :-)
> Yeah... it's also very misleading because it compares kauth_cred_t
> with a struct uucred. :) I guess I'll name it kauth_cred_uucmp()?

i vote for kauth_cred_{compare,convert}_uucred.