Subject: Re: tape drive instrumentation round 2
To: Matt Thomas <>
From: Brett Lymn <>
List: tech-kern
Date: 03/06/2006 10:59:17
On Sun, Mar 05, 2006 at 08:36:54AM -0800, Matt Thomas wrote:
> This should be call dk_iostats;

I know that this is a convention, but there are ample examples of
structures without the foo_ prefix on the fields - to my mind they
should be unnecessary.  You often see:

dk->dk_iostats = blah;

Which, to me, looks redundant compared to:

dk->iostats = blah;

About the only reason I can think of to have the structure element
prefixes there are for people who really couldn't be bothered thinking
of a vaguely meaningful name for their structure pointer (say, struct
disk p) and need the visual reminder of what the hell p is - which,
imho, is bad coding style.

Not saying, no I won't do it but, to be honest, I am wary about
perpetuating something that looks to have been done for a not very
good reason in the first place.
> Alas, I didn't see <sys/iostats.h>

Alas, you missed the bit about the extra files being in
iostat_patch.tar.gz in /pub/NetBSD/misc/blymn on

Brett Lymn