Subject: Re: yamt-uio_vmspace branch
To: None <elad@NetBSD.org>
From: YAMAMOTO Takashi <email@example.com>
Date: 12/31/2005 22:17:35
> > i'd like to request reviews and comments at this point,
> > so that i don't have to sweep code many times. :)
> Could you please elaborate a bit on what these changes are supposed to
> do? :)
ktrace-lwp branch changed uio_procp to uio_lwp.
IMO, it was a mistake because what uio needs to describe is
an address space, not a thread.
rather than just reverting the change, i'd like to go further
as a one step. a vmspace (or a vm_map) is more appropriate than a process.
i guess that the change makes implementations of aio-like things