Subject: Re: splraiseipl()
To: YAMAMOTO Takashi <email@example.com>
From: Iain Hibbert <firstname.lastname@example.org>
Date: 11/05/2005 20:25:48
On Sun, 6 Nov 2005, YAMAMOTO Takashi wrote:
>>> IPL_* are the appropriate values to use, I think. IPL_xxx should
>>> correspond directly to splxxx(), so there is no need for additional
>>> constants that would basically be aliases of IPL_*.
>> if that is so, then why is splraiseipl() necessary?
> because it's the cleanest way i can think of
> to parametrize IPLs in MI subsystems.
> please suggest an alternative, if you have any better idea.
Whats wrong with splraise() for the name? It looks to me like some
architectures are already using that in the same way that you are
proposing use of splraiseipl() - do any use it differently?
From your patch, I see eg hp700 does use splraise with a mask value
instead of the IPL value, but that could be solved easily enough by
use of _splraise at MD level instead as seems to be done in eg evpmips