Subject: Re: splraiseipl()
To: YAMAMOTO Takashi <>
From: Jason Thorpe <>
List: tech-kern
Date: 11/01/2005 09:11:32
On Nov 1, 2005, at 5:39 AM, YAMAMOTO Takashi wrote:

> splraiseipl() is an MD/MI interface found in newlock branch.
> basically splraiseipl(IPL_BIO) == splbio().
> i'd like to see it in trunk, because i'd like to use it for workqueue.
> (and maybe for callout and kcont.)

I'd like to see it in the trunk, too! :-)

> now, some questions before digging much into MD code:
> - it (ab)uses IPL_ values which is used for eg. pci_intr_establish().
>   is it worth to introduce another set of definitions eg. SPL_BIO?

IPL_* are the appropriate values to use, I think.  IPL_xxx should  
correspond directly to splxxx(), so there is no need for additional  
constants that would basically be aliases of IPL_*.

> - a developer said its name ("splraiseipl") is weired.
>   any better name suggestions?

Maybe just "spl(xxx)"?

> - which set of splxxx is considered be usable from MI code?
>   eg. while spl(9) mentions about splserial, it doesn't seem to be
>   available for some ports.

I think IPL_SERIAL should be an MI definition.  If a given platform  
doesn't support it, I suppose we could always use #ifdef.

-- thorpej