Subject: splraiseipl()
To: None <>
From: YAMAMOTO Takashi <>
List: tech-kern
Date: 11/01/2005 22:39:52

splraiseipl() is an MD/MI interface found in newlock branch.
basically splraiseipl(IPL_BIO) == splbio().
i'd like to see it in trunk, because i'd like to use it for workqueue.
(and maybe for callout and kcont.)

now, some questions before digging much into MD code:

- it (ab)uses IPL_ values which is used for eg. pci_intr_establish().
  is it worth to introduce another set of definitions eg. SPL_BIO?

- a developer said its name ("splraiseipl") is weired.
  any better name suggestions?

- which set of splxxx is considered be usable from MI code?
  eg. while spl(9) mentions about splserial, it doesn't seem to be
  available for some ports.