Subject: Re: kern.showallprocs implementation
To: None <tech-kern@NetBSD.org>
From: Juan RP <firstname.lastname@example.org>
Date: 08/30/2005 12:33:34
On Mon, 29 Aug 2005 23:46:38 -0400 (EDT)
der Mouse <mouse@Rodents.Montreal.QC.CA> wrote:
> >> security.bsd.hideproc
> >> security.bsd.hideinet
> > If we use names like these, I'd prefer that we use the positive name
> > instead of the negative name. Ie:
> > security.bsd.showproc (defaults to 1)
> > security.bsd.showinet (defaults to 1)
> > [...prior art...FreeBSD...]
> I don't see any reason we couldn't have both .hideproc and .showproc,
> with complementary values (each changing whenever the other is
> The only downside I see to it is user confusion, both intra-NetBSD
> ("why two variables for the same thing?") and inter-BSD ("why are Net
> and Free different here?").
> I prefer positive names too, in isolation - but I think inter-BSD
> compatability is the stronger force here.
I agree here: positive names and two nodes (showproc/showinet).