Subject: Re: kern.showallprocs implementation
To: None <>
From: der Mouse <mouse@Rodents.Montreal.QC.CA>
List: tech-kern
Date: 08/29/2005 23:46:38
>> security.bsd.hideproc
>> security.bsd.hideinet
> If we use names like these, I'd prefer that we use the positive name
> instead of the negative name.  Ie:
>    security.bsd.showproc (defaults to 1)
>    security.bsd.showinet (defaults to 1)
> [...prior art...FreeBSD...]

I don't see any reason we couldn't have both .hideproc and .showproc,
with complementary values (each changing whenever the other is

The only downside I see to it is user confusion, both intra-NetBSD
("why two variables for the same thing?") and inter-BSD ("why are Net
and Free different here?").

I prefer positive names too, in isolation - but I think inter-BSD
compatability is the stronger force here.

/~\ The ASCII				der Mouse
\ / Ribbon Campaign
 X  Against HTML
/ \ Email!	     7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B